Click here to return to the home page.
Image of a road.
Who's Online
2 registered (Carrotious, N22MOG), 53 Guests and 8 Spiders online.
Key: Admin, Global Mod, Mod
Latest Photos
The winter M3W
SwanMog Christmas party
Finished Plus 4 Side View
Mkiss Mog +4 fourseater
Management of cooling air flow
Newest Topics
Spot lights
by Craig Jezz
18/01/19 11:23 PM
Aero Air Bag Help
by jonathan7barrow
18/01/19 08:05 PM
VDO Clock Set
by AZJowett
18/01/19 06:23 PM
ROY POW power pack gets the Roadster started ...
by dmh
18/01/19 05:57 PM
Workshop Note -Steering Damper
by DaveW
18/01/19 05:19 PM
fan knob only working on one speed
by tom+4
18/01/19 04:49 PM
S&S X-Wedge Manual Found!
by AZJowett
18/01/19 03:22 PM
Newest Members
PJS, 250swb, Mkiss, jacquesj, Dodger
6332 Registered Users
Shout Box

Forum Stats
6,332 Registered Members
33 Forums
33,991 Topics
543,896 Posts

Most users ever online: 341 @ 11/02/18 10:30 PM
Today's Birthdays
BertR
Page 1 of 3 1 2 3 >
Topic Options
#550142 - 26/12/18 09:56 AM Non starting Plus4
PAUL21 Offline
New to Talk Morgan

Registered: 13/01/16
Posts: 5
Can anyone suggest a solution, I turn the key in the ignition. but the lock symbol won’t go out ,This is my first time on the forum,
Merry Christmas ,
Paul21

Top
#550148 - 26/12/18 10:14 AM Re: Non starting Plus4 [Re: PAUL21]
Tresco Offline
Just Getting Started

Registered: 13/11/16
Posts: 58
Loc: Thatcham
Have you lost the little bit in the key for the immobiliser.
_________________________
Ian

70th Anniversary 4/4 Edition (1976)

Top
#550149 - 26/12/18 10:17 AM Re: Non starting Plus4 [Re: PAUL21]
teifistar Offline
Learner Plates Off!

Registered: 18/11/15
Posts: 333
Loc: Carmarthen
If you have a spare key, try that. If it works then maybe you have lost the immobiliser chip in the key.
_________________________
"Hasta la victoria siempre"

Top
#550151 - 26/12/18 10:21 AM Re: Non starting Plus4 [Re: PAUL21]
PAUL21 Offline
New to Talk Morgan

Registered: 13/01/16
Posts: 5
I have tried both keys , the spare is brand new and unused!!

Top
#550158 - 26/12/18 10:48 AM Re: Non starting Plus4 [Re: PAUL21]
teifistar Offline
Learner Plates Off!

Registered: 18/11/15
Posts: 333
Loc: Carmarthen
I don't know if you are a member of the MSCC, if you are then in the December issue of Miscellany, Dave Wellings has a piece about keys and immobilisers, worth a read it could be related to your problem
_________________________
"Hasta la victoria siempre"

Top
#550160 - 26/12/18 10:52 AM Re: Non starting Plus4 [Re: PAUL21]
Richard Wood Offline
Has a lot to Say!

Registered: 03/02/16
Posts: 1395
Loc: East Harling, Norfolk UK
Try charging the battery. One member on here found the immobiliser a little finicky about less than optimum battery volts.

Thread here
_________________________
Richard

2018 Roadster - Red/Magnolia - "Morton"
1967 Land Rover series 2a SWB
1960 Velocette Venom

Top
#550161 - 26/12/18 10:52 AM Re: Non starting Plus4 [Re: PAUL21]
John V6 Offline

Member of the Inner Circle

Registered: 21/07/07
Posts: 12634
Loc: Suffolk
Can you give us more details on what the car is please.
Later cars have an immobiliser ring in the lock.
If the battery is low it may not work well.
As said search for the Dave Wellings thread on this
_________________________
JohnV6
2006 Indigo Blue Roadster S1

Top
#550163 - 26/12/18 10:56 AM Re: Non starting Plus4 [Re: PAUL21]
Alan Patterson Offline
Has a lot to Say!

Registered: 07/10/08
Posts: 1425
Loc: Kent
Here's Dave's thread on the subject
http://www.talkmorgan.com/ubbthreads.php/topics/539514/1
There is an issue with later Plus 4's. Try taking the key out of the ignition then rub the fob against the ignition barrel. This is usually sufficient to get the chip close enough to the induction loop to disable the immobiliser. Once the light goes out you have 30 seconds to insert the key and start the car.
_________________________
Regards
Alan
AP08 MOG
2016 Plus 4 GDi - Mazda Soul Red Metallic

Top
#550171 - 26/12/18 11:24 AM Re: Non starting Plus4 [Re: PAUL21]
DaveW Offline
Roadster Guru
Member of the Inner Circle

Registered: 11/12/08
Posts: 16778
Loc: South Yorkshire
Put the key in the ignition Paul. Don't turn it.

Put a battery conditioner on and the immobiliser will disarm in a few minutes.

PS - if my theory holds true, your Plus 4 will be 2016 onwards with an autophoretic coated chassis........
_________________________
DaveW
2005 Corsa Red Roadster S1
2016 Saffron Yellow (Narrow) Plus 4

Top
#550196 - 26/12/18 01:14 PM Re: Non starting Plus4 [Re: PAUL21]
PAUL21 Offline
New to Talk Morgan

Registered: 13/01/16
Posts: 5
Thank you all for your help, l have had the car on a trickle charge which said the battery was charged, but when I used an additional jump start the car started immediately and with all keys
Beautiful day in Edinburgh, now can take the car out ,,but will not turn engine off till I return,
Thank you all again

Top
#550198 - 26/12/18 01:21 PM Re: Non starting Plus4 [Re: PAUL21]
John V6 Offline

Member of the Inner Circle

Registered: 21/07/07
Posts: 12634
Loc: Suffolk
Great news. Enjoy the grin factor
_________________________
JohnV6
2006 Indigo Blue Roadster S1

Top
#550199 - 26/12/18 01:21 PM Re: Non starting Plus4 [Re: PAUL21]
PAUL21 Offline
New to Talk Morgan

Registered: 13/01/16
Posts: 5
Sorry, forgot to mention I am a member of the MSCC, I have this 2015 plus 4,and a 2018 Plus 8 50th Anniversary model
Cheers Paul

Top
#550200 - 26/12/18 01:25 PM Re: Non starting Plus4 [Re: DaveW]
BobtheTrain Offline

Part of the Furniture

Registered: 15/04/14
Posts: 4851
Loc: Renfrewshire
Originally Posted By DaveW
Put the key in the ignition Paul. Don't turn it.

Put a battery conditioner on and the immobiliser will disarm in a few minutes.

Dave W to the rescue, again!
_________________________
Best Regards
Lang may yer lum reek

Top
#550202 - 26/12/18 01:31 PM Re: Non starting Plus4 [Re: PAUL21]
griffo Offline
Learner Plates Off!

Registered: 31/07/14
Posts: 388
Loc: Cornwall
Well done Paul,
It's so upsetting when this kind of thing happens. It seems to me immobilisers are almost designed to prevent the rightful owners of cars from enjoying them. The chip fell out of my Plus 4 key in Italy and it wouldn't start. Thank God I carried the spare key. FYI the people re-programming my ECU for the Ecoboost conversion will delete the immobiliser at my request so it will always start with the key. I shall risk that the rarity of the Mog, the steering lock and my own "secret switch" will prevent theft.
_________________________
www.griffopix.com

Top
#550203 - 26/12/18 01:38 PM Re: Non starting Plus4 [Re: PAUL21]
DaveW Offline
Roadster Guru
Member of the Inner Circle

Registered: 11/12/08
Posts: 16778
Loc: South Yorkshire
Good news. So it seems that the galvanised chassis cars are not immune from this!
_________________________
DaveW
2005 Corsa Red Roadster S1
2016 Saffron Yellow (Narrow) Plus 4

Top
#550209 - 26/12/18 02:01 PM Re: Non starting Plus4 [Re: DaveW]
Graham, G4FUJ Offline
Salty Sea Dog
Member of the Inner Circle

Registered: 03/07/07
Posts: 21438
Loc: Cheltenham, Glos. UK
I wonder how the battery conditioner was connected - direct to the battery, or via the accessory socket?
_________________________
Graham (G4FUJ)

D8921 L44FOR '93 4/4 Giallo Fly 2 seat smile
'90 LR 90 SW
'07 MINI Cooper

Top
#550258 - 26/12/18 06:46 PM Re: Non starting Plus4 [Re: PAUL21]
PAUL21 Offline
New to Talk Morgan

Registered: 13/01/16
Posts: 5
Hi Graham, is was direct to the battery with a lead which I could unplug when taking the car out,it is a fairly basic Halfords unit with a simple green light showing when charged, ,
Would you believe it, took the car out for an hour, About 2ish, it’s been parked in my garage and now won’t start, !!! Maybe the battery is not holding a charge
I have a 20 amp charger will put it on overnight , Bollocks !!
Cheers Paul

Top
#550305 - 27/12/18 07:21 AM Re: Non starting Plus4 [Re: PAUL21]
John V6 Offline

Member of the Inner Circle

Registered: 21/07/07
Posts: 12634
Loc: Suffolk
Paul,
buy a conditioner like CTEK not a charger. You need to trickle charge to keep the battery healthy.
_________________________
JohnV6
2006 Indigo Blue Roadster S1

Top
#550308 - 27/12/18 07:39 AM Re: Non starting Plus4 [Re: John V6]
Graham, G4FUJ Offline
Salty Sea Dog
Member of the Inner Circle

Registered: 03/07/07
Posts: 21438
Loc: Cheltenham, Glos. UK
I'll second that John!
Also Paul, check your battery electrolyte level. smile
_________________________
Graham (G4FUJ)

D8921 L44FOR '93 4/4 Giallo Fly 2 seat smile
'90 LR 90 SW
'07 MINI Cooper

Top
#550352 - 27/12/18 11:58 AM Re: Non starting Plus4 [Re: PAUL21]
Paul F Offline

Talk Morgan Expert

Registered: 20/08/10
Posts: 2117
Loc: Costock, South Nottinghamshire...
It may be that you have cooked your battery - Graham’s suggestion re electrolyte level is the first place I would look.

Our 4/4 sits on a CTEK charger when not being used (wired to battery with a fused lead - not through the cigarette lighter socket) and we have not had a problem.
_________________________
Paul
Costock, UK
2014 4/4 Rolls Royce Garnet Red
Disco 4
Teddy - 17h1 Irish Draught cross

Top
#550559 - 28/12/18 04:46 PM Re: Non starting Plus4 [Re: PAUL21]
xc68anc Offline
Just Getting Started

Registered: 16/11/18
Posts: 28
Loc: Germany, Rhein-Main Area
If it's a 2015 car, and battery - I think the battery is sealed.

In cause the place they are mounted is still in technical sence "not a nice place for a long life". So now it's cold outside and in the garage. I think it's reached the end of it life.

Good chargers and conditioners shows it if the battery has a problem. And: with the most good conditioners you can also charge such a small battery like fitted in the morgan.

Best wishes

René

Top
Page 1 of 3 1 2 3 >

Moderator:  Aeroman, Boshly, Simon