Click here to return to the home page.
Classic Morgans
Who's Online
15 registered (Alistair, Ulli, Northernmorgan, Q8morgan, Gambalunga, Black Adder, Hamwich, SFG, Jabax4, BobtheTrain, pandy, SAE, dmh, AZJowett, Bloggins), 111 Guests and 11 Spiders online.
Key: Admin, Global Mod, Mod
Latest Photos
VictoryMog June 2019 Form and Car Passes
2019 Classic Car & Restoration Show
Triumph TR4a-IRS
A day out in Felixstowe
Ecoboost Plus 4 rolling road session
Newest Topics
Magnum Tuning Performance Chip for S&S Engine
by Bunny
23/03/19 12:04 PM
Thoughts please
by meabh
23/03/19 11:05 AM
Rear tyres for the Coupe, whats the latest ?
by Alistair
23/03/19 08:26 AM
The Brabham BT62 will race at Le Mans
by +8Rich
22/03/19 10:49 PM
Fitting a Panhard Rod
by Button
22/03/19 07:51 PM
Carol Vorderman joins MMC asadvisor ?
by sospan
22/03/19 06:59 PM
Mercedes E300 Hybrid
by Budster
22/03/19 06:26 PM
Newest Members
Jabax4, UTE, robert l, RogerU, GIB
6422 Registered Users
Shout Box

Forum Stats
6,422 Registered Members
33 Forums
34,605 Topics
557,541 Posts

Most users ever online: 341 @ 11/02/18 10:30 PM
Today's Birthdays
No Birthdays
Topic Options
#550793 - 30/12/18 08:32 AM Electric steering issue on Roadster
Richard Wood Offline
Talk Morgan Enthusiast

Registered: 03/02/16
Posts: 1587
Loc: East Harling, Norfolk UK
Not sure how long the electric steering assistance has been standard fit on latest Roadsters or how long it was an option before that, so unsure how much experience there is out there.

However just noticed a distinct whirring noise from mine when manouvering in or out of road junctions, despite my diminishing hearing. The noise cuts in just after wheel is turned in either direction, and continues for a similar short time after wheel is straightened.

It may have been there from new but its significantly more noticeable now with 3500+ miles on the clock. Anyone else with electric steering noticed this?
_________________________
Richard

2018 Roadster - Red/Magnolia - "Morton"
1967 Land Rover series 2a SWB
1960 Velocette Venom

Top
#550850 - 30/12/18 12:30 PM Re: Electric steering issue on Roadster [Re: Richard Wood]
Burgundymog Offline

Talk Morgan Addict

Registered: 11/05/14
Posts: 3437
Loc: Essex
Originally Posted By Richard Wood
Not sure how long the electric steering assistance has been standard fit on latest Roadsters or how long it was an option before that, so unsure how much experience there is out there.

However just noticed a distinct whirring noise from mine when manouvering in or out of road junctions, despite my diminishing hearing. The noise cuts in just after wheel is turned in either direction, and continues for a similar short time after wheel is straightened.

It may have been there from new but its significantly more noticeable now with 3500+ miles on the clock. Anyone else with electric steering noticed this?


I have the first +4 (press car) fitted with electric power steering. Never experience any noise Richard, suggest a trip to the dealer.
_________________________
Keith
2013 narrow bodied + 4 Ruby. Wolf performance Re-map suspension mods and K&N cone filter.

Top
#550857 - 30/12/18 01:13 PM Re: Electric steering issue on Roadster [Re: Richard Wood]
Stringers Best Mate Offline

Talk Morgan Sage

Registered: 16/10/13
Posts: 6271
Loc: Northamptonshire UK
No noise at all from the steering on mine either, Richard..
_________________________
Steve

Top
#550858 - 30/12/18 01:14 PM Re: Electric steering issue on Roadster [Re: Richard Wood]
lowebird Offline
Talk Morgan Addict

Registered: 11/01/11
Posts: 3265
Loc: norfolk, UK
Same here Richard, after 3 years of wheel twirling, no noise thank goodness. Sounds like it is going to cost year some of your Xmas pressy money!!
_________________________
Here for a good time not a long time!!
Reg

Top
#550890 - 30/12/18 04:58 PM Re: Electric steering issue on Roadster [Re: Richard Wood]
Richard Wood Offline
Talk Morgan Enthusiast

Registered: 03/02/16
Posts: 1587
Loc: East Harling, Norfolk UK
Thanks for responses. Needed an excuse to visit KH anyway.

Will get them to check bottom hose issue as well. Couldn't see any damage whilst jacked up for greasing today, but hose resting on steering rack support bracket with neoprene pad between doesn't allude confidence.
_________________________
Richard

2018 Roadster - Red/Magnolia - "Morton"
1967 Land Rover series 2a SWB
1960 Velocette Venom

Top
#550920 - 30/12/18 06:43 PM Re: Electric steering issue on Roadster [Re: Richard Wood]
sid Offline

L - Learner Plates On

Registered: 21/08/09
Posts: 122
Loc: Leics UK
Hi Richard,

There shouldn't be any noise from the steering motor, so worth getting it checked whilst under warranty.

I've just replaced the bottom hose on mine (Phil Ledgerwood sent me a repalcemnet under warranty), and the design has been altered slightly so that it no longer fouls the inner wing bolts, so with yours being a newer model maybe there isn't an issue. But worth checking all the same. And don't forget to check if the brake pipe fouls the brake servo vacuum hose, too.
_________________________
Sid

2014 3.7 Roadster in Ferrari Le Mans Blue
Ex Indigo Blue '99 +4
MogMMX Innovations winner

Top
#550940 - 30/12/18 08:49 PM Re: Electric steering issue on Roadster [Re: Richard Wood]
Richard Wood Offline
Talk Morgan Enthusiast

Registered: 03/02/16
Posts: 1587
Loc: East Harling, Norfolk UK
Thanks Sid, will add brake pipe/servo check to the list.

Following your earlier thread I checked bottom hose today from underneath, and it is clearly resting on top of the offside steering rack clamp. Pushing the hose up and away from its resting place there doesn't seem to be any damage yet, but factory must have been aware as they have secured a neoprene pad to top of rack clamp, although this is only visible from wheel side.
_________________________
Richard

2018 Roadster - Red/Magnolia - "Morton"
1967 Land Rover series 2a SWB
1960 Velocette Venom

Top
#551047 - 31/12/18 05:00 PM Re: Electric steering issue on Roadster [Re: Richard Wood]
lowebird Offline
Talk Morgan Addict

Registered: 11/01/11
Posts: 3265
Loc: norfolk, UK
I did that to mine some time ago and so far, so good. How can these things still be happening. It just needs a slightly better curve for goodness sake.
_________________________
Here for a good time not a long time!!
Reg

Top
#551127 - 01/01/19 12:46 AM Re: Electric steering issue on Roadster [Re: Richard Wood]
DaveW Offline
Roadster Guru
Member of the Inner Circle

Registered: 11/12/08
Posts: 17132
Loc: South Yorkshire
The neoprene pad was a more recent addition. My Plus 4 has one. I've posted a fair bit about chafing here and it gets a mention in my book! read
_________________________
DaveW
2005 Corsa Red Roadster S1
2016 Saffron Yellow (Narrow) Plus 4

Top
#551624 - 04/01/19 08:33 AM Re: Electric steering issue on Roadster [Re: Richard Wood]
Richard Wood Offline
Talk Morgan Enthusiast

Registered: 03/02/16
Posts: 1587
Loc: East Harling, Norfolk UK
Update on electric steering issue. After greasing front suspension, which I do every 1000 miles, problem seems to have dissapeared.

Only change is that I'm using a new flex hose connection on my Wanner grease gun and this allows positive clip on connection to grease nipples, so it all goes where it should.
_________________________
Richard

2018 Roadster - Red/Magnolia - "Morton"
1967 Land Rover series 2a SWB
1960 Velocette Venom

Top

Moderator:  Aeroman, Boshly, Simon