Click here to return to the home page.
Image of a road.
Who's Online
6 registered (Frank K, RB1, Crunchie Gears, Martinus, Knucklefreak, M3W55), 118 Guests and 15 Spiders online.
Key: Admin, Global Mod, Mod
Latest Photos
SwanMog Christmas party
Finished Plus 4 Side View
Mkiss Mog +4 fourseater
Management of cooling air flow
Morgan Rutherford Modsports +8
Newest Topics
12 volt wiring help please!
by Fat Wolfie
15/01/19 07:09 PM
Ford VW Alliance confirmed
by +8Rich
15/01/19 06:56 PM
Spotted this web site
by Jack The Lad
15/01/19 02:43 PM
Jubilee Sailing Trust
by Gambalunga
15/01/19 02:13 PM
Just in case....
by Gambalunga
15/01/19 02:07 PM
nc 500 advice
by B3MOG
14/01/19 08:25 PM
Towing a trailer in France
by Island Mog
14/01/19 08:18 PM
Newest Members
PJS, 250swb, Mkiss, jacquesj, Dodger
6332 Registered Users
Shout Box

Forum Stats
6,332 Registered Members
33 Forums
33,973 Topics
543,315 Posts

Most users ever online: 341 @ 11/02/18 10:30 PM
Today's Birthdays
olleyjp, tarutino
Page 1 of 3 1 2 3 >
Topic Options
#553033 - 10/01/19 04:21 PM Brake Lights not Working
V8Dave Offline
Just Getting Started

Registered: 24/11/16
Posts: 41
Loc: West Auckland, Co. Durham
Hi.
The brake lights on my 2010 Roadster are not working. I don't believe it is the fuse as the reversing light works and, according to the fuse box listing this is on the same fuse. The brake light switch is mounted at the base of the brake pedal. I have disconnected the wires from the brake switch and tried jumping them but still no brake lights. Has anyone any suggestions to locate the problem.

Top
#553055 - 10/01/19 05:09 PM Re: Brake Lights not Working [Re: V8Dave]
John V6 Offline

Member of the Inner Circle

Registered: 21/07/07
Posts: 12631
Loc: Suffolk
Check the earth at the rear of the car.
Is there power at the switch?
_________________________
JohnV6
2006 Indigo Blue Roadster S1

Top
#553060 - 10/01/19 05:25 PM Re: Brake Lights not Working [Re: John V6]
V8Dave Offline
Just Getting Started

Registered: 24/11/16
Posts: 41
Loc: West Auckland, Co. Durham
Thanks for the quick response I will check the earth at the back of the car tomorrow. I am not sure there is power at the switch.

Top
#553071 - 10/01/19 06:05 PM Re: Brake Lights not Working [Re: V8Dave]
clubsport Offline
Just Getting Started

Registered: 12/08/08
Posts: 32
Loc: Kent / Se London
Once you have checked the fuse and earth, I Would buy a brake light switch, fit the new one, if it makes no difference then you have a spare.

I have got through a couple of these over the years on my 4/4.

Top
#553086 - 10/01/19 07:00 PM Re: Brake Lights not Working [Re: V8Dave]
xc68anc Offline
Just Getting Started

Registered: 16/11/18
Posts: 27
Loc: Germany, Rhein-Main Area
In cause the fuse mustn't be on the right place it's the first step to have a look about powerinput at the switch. The easy way: take a 12v bulb and put one cable to middle contactpoint and the other cable to the outside metal.

If the switch is broken the light would work if you fix the cables together as you had done.

If there is no power on the cable at the pedal and no fuse is broken (check ecery fuse!) than there may be a problem in the wiring.

Good luck!

René

Top
#553094 - 10/01/19 07:22 PM Re: Brake Lights not Working [Re: V8Dave]
sospan Offline
Charter Member

Registered: 31/05/10
Posts: 5808
Loc: Llanelli
I had similar on my old 4/4 on the driver side rear indicator. I did the “wiggle” test on the wiring by reaching up under the wing and wiggling the wires. The earth wire was the problem. I took the light fitting off and the eatyh wire was simple rivetted to the plate and was not a tight fit. I renewed the fit , put vaseline over it and it sorted the problem. So, do as JohnV6 suggested. Check earthing.
A lot of the wiring on a Morgan is exposed and it is worth giving it a check, especially earth points.
_________________________
Red Plus8

Top
#553131 - 10/01/19 11:26 PM Re: Brake Lights not Working [Re: V8Dave]
Jacques Offline
New to Talk Morgan

Registered: 21/12/08
Posts: 19
Loc: Between Paris & Montlhery - Fr...
Check all the fuses as the fuse box listing is only a joke !
My two cents
_________________________
Happy Morgan +8 (2001) owner

Top
#553174 - 11/01/19 11:14 AM Re: Brake Lights not Working [Re: V8Dave]
Felix42 Offline
Talk Morgan Regular

Registered: 17/12/13
Posts: 829
Loc: Newton Abbot, South Devon UK
The hydraulic brake light switches in older Morgans have a habit of burning out because the addition of the cobra light put too much current through them. The switch has very crude contacts inside (I sawed on in half once to have a look).

The solution to this is to fit a relay and/or LED lightbulbs.
_________________________
John

Silver 2005 S1 Roadster V6 - Henrietta

Top
#553181 - 11/01/19 11:35 AM Re: Brake Lights not Working [Re: V8Dave]
DaveW Offline
Roadster Guru
Member of the Inner Circle

Registered: 11/12/08
Posts: 16763
Loc: South Yorkshire
I put a microswitch on the pedal of my 2005, with a relay. You could also retro fit the current pedal switch.
_________________________
DaveW
2005 Corsa Red Roadster S1
2016 Saffron Yellow (Narrow) Plus 4

Top
#553185 - 11/01/19 12:05 PM Re: Brake Lights not Working [Re: V8Dave]
V8Dave Offline
Just Getting Started

Registered: 24/11/16
Posts: 41
Loc: West Auckland, Co. Durham
Hi,

Checked the earths and all of the fuses and all OK. It would appear that there is power reaching the switch terminals as the test light lit when connected to the live wire coming in. However when you bridge the two leads there are no brake lights coming on. Would I be right in assuming there is a connection problem between the switch and the brake lights and is there a splitter connector at the rear of the car prior to the connectors at each lamp.
Thanks

Top
Page 1 of 3 1 2 3 >

Moderator:  Aeroman, Boshly, Simon