Click here to return to the home page.
Image of a road.
Who's Online
3 registered (Heinz, Andrew Kidney, MarioCP), 21 Guests and 11 Spiders online.
Key: Admin, Global Mod, Mod
Latest Photos
M3W Tour of New Zealand 2019
Concept Royal Enfield V Twin
Go Outdoors
Morgan 3 wheeler oil cooler
Show us your Bike
Newest Topics
Recommended engine oil for a 4/4 engine 1.6 TI VCT
by Heinz
19/03/19 01:52 AM
One Shot Oiler
by britmog
18/03/19 11:32 PM
Finally coming for you
by Bourbonmog
18/03/19 11:23 PM
Continuously asked, Is it Real or a Kit?
by PocketRocket
18/03/19 08:31 PM
Essential Three Wheeler tool kit
by LightSpeed
18/03/19 08:26 PM
Krazy Horse Stage 1 or 2 Exhaust Noise - Advice
by Black Adder
18/03/19 06:44 PM
Bus Gate
by N22MOG
18/03/19 06:00 PM
Newest Members
Jabax4, UTE, robert l, RogerU, GIB
6422 Registered Users
Shout Box

Forum Stats
6,422 Registered Members
33 Forums
34,559 Topics
556,493 Posts

Most users ever online: 341 @ 11/02/18 10:30 PM
Today's Birthdays
gazum
Page 2 of 3 < 1 2 3 >
Topic Options
#553188 - 11/01/19 12:31 PM Re: Brake Lights not Working [Re: V8Dave]
MOG 615 Offline
Has a lot to Say!

Registered: 24/09/14
Posts: 1310
Loc: London
Dave

This sounds like a classic pressure switch failure to me as mentioned by John above. I assume the Series 1 Roadsters used the same switch as my 1999 +8? (Others like DaveW will know better than I)

Replacement of the switch itself is the only cure.

This is not exactly easy unless you can raise the car high enough to get good access from underneath. If you can, just remember to hold the switch body very firmly as you release each of the pipes , you don't want to bend/twist them as the job becomes a lot bigger if you do.
_________________________
Andy G
1999 +8 , Indigo Blue.
Ex-John McKecknie/Mike Duncan 1955 +4 racer.

Top
#553191 - 11/01/19 12:39 PM Re: Brake Lights not Working [Re: V8Dave]
Richard Wood Offline
Talk Morgan Enthusiast

Registered: 03/02/16
Posts: 1579
Loc: East Harling, Norfolk UK
According to latest parts manual for classics the brake light circuit between switch and lamps passes through a four way connector which also supports the reversing light circuit. Not sure where this connector is located but pin 2 feeds all three brake lights.

I would suspect a connection issue there. The earth's are split anyway so would only affect one lamp which doesn't seem to be the case.
_________________________
Richard

2018 Roadster - Red/Magnolia - "Morton"
1967 Land Rover series 2a SWB
1960 Velocette Venom

Top
#553196 - 11/01/19 01:03 PM Re: Brake Lights not Working [Re: V8Dave]
DaveW Offline
Roadster Guru
Member of the Inner Circle

Registered: 11/12/08
Posts: 17118
Loc: South Yorkshire
Yes S1 is standard pressure switch. I left mine in place and piggy backed the microswitch across the terminals through a relay. One of my early posts covers it.
_________________________
DaveW
2005 Corsa Red Roadster S1
2016 Saffron Yellow (Narrow) Plus 4

Top
#553202 - 11/01/19 01:23 PM Re: Brake Lights not Working [Re: V8Dave]
John V6 Offline

Member of the Inner Circle

Registered: 21/07/07
Posts: 12868
Loc: Suffolk
I went the LED route on mine.
_________________________
JohnV6
2006 Indigo Blue Roadster S1

Top
#553209 - 11/01/19 02:31 PM Re: Brake Lights not Working [Re: V8Dave]
Felix42 Offline
Talk Morgan Regular

Registered: 17/12/13
Posts: 858
Loc: Newton Abbot, South Devon UK
_________________________
John

Silver 2005 S1 Roadster V6 - Henrietta

Top
#553230 - 11/01/19 03:29 PM Re: Brake Lights not Working [Re: V8Dave]
Graham, G4FUJ Offline
Salty Sea Dog
Member of the Inner Circle

Registered: 03/07/07
Posts: 21868
Loc: Cheltenham, Glos. UK
Originally Posted By V8Dave
Hi.
... The brake light switch is mounted at the base of the brake pedal...

So, a micro switch I presume and not one in the hydraulic brake pipe?
_________________________
Graham (G4FUJ)

D8921 L44FOR '93 4/4 Giallo Fly 2 seat smile
'90 LR 90 SW
'07 MINI Cooper

Top
#553238 - 11/01/19 03:39 PM Re: Brake Lights not Working [Re: V8Dave]
John V6 Offline

Member of the Inner Circle

Registered: 21/07/07
Posts: 12868
Loc: Suffolk
It should be a micro switch by the age of the car Graham.
_________________________
JohnV6
2006 Indigo Blue Roadster S1

Top
#553243 - 11/01/19 04:07 PM Re: Brake Lights not Working [Re: V8Dave]
V8Dave Offline
Just Getting Started

Registered: 24/11/16
Posts: 43
Loc: West Auckland, Co. Durham
Hi All,

It is a micro switch at the base of the brake pedal. There is power to the switch but when the two leads are connected there is still no brake lights. Will concentrate the search tomorrow for the four way connector that Richard mentions and hope the issue is found there. Now just need to locate it. I am hoping it's under the spare wheel.

Thanks Dave

Top
#553327 - 11/01/19 10:24 PM Re: Brake Lights not Working [Re: John V6]
Graham, G4FUJ Offline
Salty Sea Dog
Member of the Inner Circle

Registered: 03/07/07
Posts: 21868
Loc: Cheltenham, Glos. UK
As I thought John from the original description. Just double checking, as a number of replies were referencing the problems experienced with the (Land Rover) hydraulic switch.

Dave, tracing wiring can be a pain. As both brake lights are not working, at least you are looking at a common section of cable/interconnection. Good chance it may be under wheel arch rather than spare wheel space. Good luck with the search. If I was closer I'd offer an extra pair of paws/eyes, test meter &c.
_________________________
Graham (G4FUJ)

D8921 L44FOR '93 4/4 Giallo Fly 2 seat smile
'90 LR 90 SW
'07 MINI Cooper

Top
#553400 - 12/01/19 11:10 AM Re: Brake Lights not Working [Re: John V6]
Roady Offline
Just Getting Started

Registered: 06/10/10
Posts: 69
Loc: returned OggieMogger
+1 - No problems since

Top
Page 2 of 3 < 1 2 3 >

Moderator:  Aeroman, Boshly, Simon