Click here to return to the home page.
Morgan 3 Wheeler
Who's Online
7 registered (Rovert, Taffmog, Dan_Lockwood, Ray, BigSteve, lloydie99, Heinz), 107 Guests and 16 Spiders online.
Key: Admin, Global Mod, Mod
Latest Photos
2019 Classic Car & Restoration Show
Triumph TR4a-IRS
A day out in Felixstowe
Ecoboost Plus 4 rolling road session
Allon White trim shop . Roadster interior changes
Newest Topics
The Brabham BT62 will race at Le Mans
by +8Rich
Yesterday at 10:49 PM
Fitting a Panhard Rod
by Button
Yesterday at 07:51 PM
Carol Vorderman joins MMC asadvisor ?
by sospan
Yesterday at 06:59 PM
Mercedes E300 Hybrid
by Budster
Yesterday at 06:26 PM
A Real Honour
by Peter J
Yesterday at 06:02 PM
just look at this
by howard
Yesterday at 05:59 PM
Quick question - 4/4 gearbox and diff oil
by nputtick
Yesterday at 03:13 PM
Newest Members
Jabax4, UTE, robert l, RogerU, GIB
6422 Registered Users
Shout Box

Forum Stats
6,422 Registered Members
33 Forums
34,601 Topics
557,462 Posts

Most users ever online: 341 @ 11/02/18 10:30 PM
Today's Birthdays
No Birthdays
Page 1 of 2 1 2 >
Topic Options
#560330 - 16/02/19 10:31 PM Finally... Something’s Gone Wrong!😂
KenShapiro Offline
Has a lot to Say!

Registered: 31/10/15
Posts: 1440
Loc: Baltimore, Maryland USA
I’ve been feeling so guilty that after three years and over 10,000 miles nothing has broken on Mo. Well, today during a brisk winter ride the smell of fuel appeared. Looks like one of the throttle body hoses ( left side) is looking wet. Not enough to spray back and ruin a windscreen or even drip. I’ll just consider myself luckily warned and replace the hoses with proper clamps. Any parts advice / links is greatly appreciated.
_________________________
The Original Ken
2016 Smith & Stankos Special
10,000 miles.

2014 BMW R9T

Top
#560339 - 16/02/19 11:01 PM Re: Finally... Something’s Gone Wrong!😂 [Re: KenShapiro]
PaulR Offline
Just Getting Started

Registered: 01/10/16
Posts: 72
Loc: Nr Haverhill UK
Ken
Its also worth checking the fuel hoses where they come under the cooling cowl as they can wear through at that point, it is quite a sharp edge. Its not immediately obvious as they are covered in the heat resistant sleeving.
_________________________
PaulR

2016 M3W

Top
#560340 - 16/02/19 11:20 PM Re: Finally... Something’s Gone Wrong!😂 [Re: PaulR]
KenShapiro Offline
Has a lot to Say!

Registered: 31/10/15
Posts: 1440
Loc: Baltimore, Maryland USA


Originally Posted By PaulR
Ken
Its also worth checking the fuel hoses where they come under the cooling cowl as they can wear through at that point, it is quite a sharp edge. Its not immediately obvious as they are covered in the heat resistant sleeving.


Will do. Just went out to check on her and the hoses look dry and there’s no odor right now.
_________________________
The Original Ken
2016 Smith & Stankos Special
10,000 miles.

2014 BMW R9T

Top
#560367 - 17/02/19 09:33 AM Re: Finally... Something’s Gone Wrong!😂 [Re: KenShapiro]
smudger1 Offline
L - Learner Plates On

Registered: 20/05/09
Posts: 159
Loc: Durham, UK
Make sure they are Ethanol resistant , there are retailers selling old stock that aren't up to the latest spec


Edited by smudger1 (17/02/19 09:43 AM)
_________________________
1999 Morgan Plus 8. 3.9 ....
1961 Alvis TD21 Series1 3 Litre Auto....

Top
#560776 - 19/02/19 02:34 AM Re: Finally... Something’s Gone Wrong!😂 [Re: KenShapiro]
06032 Offline
L - Learner Plates On

Registered: 02/11/18
Posts: 163
Loc: CT, USA
...and EFI rated.
_________________________
'17 M3W
'08 Ural Gear Up

Top
#560812 - 19/02/19 11:57 AM Re: Finally... Something’s Gone Wrong!😂 [Re: 06032]
Chris99 Offline

Talk Morgan Expert

Registered: 17/07/13
Posts: 2526
Loc: West Sussex, UK
I replaced my fuel hoses with Cohline 2240.0600 7.3mm bore and stainless steel rounded edge fuel hose clips - 11 to 13mm
_________________________
Red Leader drive

Top
#560888 - 19/02/19 06:57 PM Re: Finally... Something’s Gone Wrong!😂 [Re: KenShapiro]
Draggin Offline

Talk Morgan Expert

Registered: 13/07/15
Posts: 2495
Loc: Detroit, Michigan, USA
Good information
_________________________
kirkusblog.com
2016 M3W John A Prestwich Special

1968 Honda CL175,and 2012 Enfield for sale







Top
#561950 - 24/02/19 06:06 PM Re: Finally... Something’s Gone Wrong!😂 [Re: KenShapiro]
KenShapiro Offline
Has a lot to Say!

Registered: 31/10/15
Posts: 1440
Loc: Baltimore, Maryland USA
Well... maybe something HASN’T finally gone wrong? First time to assess after the incident. Just went out to the garage mahal... removed the “Caution Hot” shroud and the fan so I’d have access to the fuel lines. Started her up and let her reach operating temp. ( I do this every weekend if she’s not being driven). No visible or olfactory evidence at all! And the gas smell was sooo overwhelming last weekend on the seven mile ride home. No drips in the garage then or now. Weird.
_________________________
The Original Ken
2016 Smith & Stankos Special
10,000 miles.

2014 BMW R9T

Top
#561992 - 24/02/19 09:04 PM Re: Finally... Something’s Gone Wrong!😂 [Re: KenShapiro]
Dan_Lockwood Online   content
Talk Morgan Regular

Registered: 23/01/14
Posts: 898
Loc: O'Fallon, Missouri USA
Originally Posted By KenShapiro
Well... maybe something HASN’T finally gone wrong? First time to assess after the incident. Just went out to the garage mahal... removed the “Caution Hot” shroud and the fan so I’d have access to the fuel lines. Started her up and let her reach operating temp. ( I do this every weekend if she’s not being driven). No visible or olfactory evidence at all! And the gas smell was sooo overwhelming last weekend on the seven mile ride home. No drips in the garage then or now. Weird.


Ken,

After having one episode of the gas issues, even though you don't see anything at this moment, and knowing the track record with this same occurrence, don't you think it would be prudent to swap out hose clamps to something a bit more reliable than the crimp clamps currently installed? Now's the opportune time to do it while you're not craving to get out on the road.

Just a thought, but obviously your choice.
_________________________
Dan

Dan's Car - Bike - Projects Photo Albums

Top
#562005 - 24/02/19 10:22 PM Re: Finally... Something’s Gone Wrong!😂 [Re: Dan_Lockwood]
M3W55 Offline
L - Learner Plates On

Registered: 19/07/18
Posts: 158
The crimped clamps had been replaced by 2016, but chris99's high quality upgrade is a good idea.

BTW, while I remember, did any of those who replaced their plug leads with magnecores notice an improvement in ignition?

Top
Page 1 of 2 1 2 >

Moderator:  Aeroman