Click here to return to the home page.
Classic Morgans
Who's Online
3 registered (Phil T, kankeL, The Austrian), 115 Guests and 19 Spiders online.
Key: Admin, Global Mod, Mod
Latest Photos
Southern Weather comes North
Island of Muhu in the rain
65 Plus 4 Four Seater back seat Lift-a-dot studs
Fuel cap seal
Touring Scotland with Anglemog.
Newest Topics
Rolls Royce Cullinan
by MJF
17/06/19 09:46 PM
Do you think I've achieved full penetration?
by Lowflyer
17/06/19 09:40 PM
"new" Top Gear
by MDS61
17/06/19 09:18 PM
Fitting wing beading to “sill”
by Phil4/4
17/06/19 08:10 PM
How reliable are current Three Wheelers.
by PaulJ
17/06/19 06:39 PM
Quarter Panel Protectors
by AndyA
17/06/19 03:26 PM
Mog19
by DaveW
17/06/19 10:53 AM
Newest Members
arnieb, BradB, PANTHRO, MarsdenRobinson, M500
6524 Registered Users
Shout Box

Forum Stats
6,524 Registered Members
33 Forums
35,386 Topics
570,991 Posts

Most users ever online: 341 @ 11/02/18 10:30 PM
Today's Birthdays
Paperix
Page 1 of 2 1 2 >
Topic Options
#573368 - 23/04/19 06:32 PM PSA - 1.6 Sigma - copper adapter is a weak link
PerryP Offline
Learner Plates Off!

Registered: 27/03/16
Posts: 396
Loc: Cheshire
Hi All,

I had the misfortune of an oil leak that has render the car grounded until I get this part in. With that in mind, I thought it best to pass along the below.

There is a copper adapter that is used to connect the oil pressure sending unit. This can be found on the back of top side of the engine on the driver's side (RHD). I knew I had a very minor leak which I thought was coming from the engine and bell housing gasket. The leak was a very small drip which over the course of a day was getting worse. I then spent the better part of the morning checking all possible areas and still came away feeling it was from the bottom.

The next day I took another stab at locating it but this time ran the engine and watched. To my surprise a small drip came from what at first looked like the connection between the oil pressure unit and the copper piece. I checked to see if it was perhaps loose only to find it was VERY loose. Gave it a 1/4 turn and something didn't feel right. I turned over the engine and was sprayed with oil. The copper part split!

A mate who is in the know mentioned that this is a weak part and Morgan specific. Being such an odd piece I figured it would take a bit of time to get one ordered but low and behold my retailer had them in stock. Seems it's common enough to keep on hand.

In short, have a look and take wipe to see if your's is sweating or not. It's a 25 quid piece - ouch - but it's metric on one end and imperial on the other. Go figure.

I would hate to think if it split whilst driving and thankful it happened on my driveway. I'll try and post a pic if the above isn't making it clear what I'm on about.

Cheers,

P
_________________________
Morgan Newb in all sense of the word...

Top
#573377 - 23/04/19 07:50 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: PerryP]
Paul F Offline

Talk Morgan Expert

Registered: 20/08/10
Posts: 2366
Loc: Costock, South Nottinghamshire...
Many thanks for posting this Perry - I will check mine.
Tempted to get a spare to keep in the car.
_________________________
Paul
Costock, UK
2014 4/4 Rolls Royce Garnet Red
Disco 4
Teddy - 17h1 Irish Draught cross

Top
#573378 - 23/04/19 07:54 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: PerryP]
+8Rich Offline

Member of the Inner Circle

Registered: 15/12/09
Posts: 20026
Loc: Devonshire
One of these failed on my 2009 Sport during the warranty period luckily it was just weeping.
_________________________
Regards Richard

1999 Indigo Blue +8
2009 4/4 Sport Green
1994 Connaught Green +8






Top
#573388 - 23/04/19 09:10 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: PerryP]
andymot Offline

Talk Morgan Regular

Registered: 11/09/14
Posts: 776
Loc: East Sussex, ENGLAND
Thanks for posting. Seems like a good spare to have in the box - whats the part number/details please? thankyou
_________________________
2015 Morgan 4/4 (Wolf tuned engine, steering and suspension)
Mazda MX5+some preserved BL relics.


Top
#573407 - 23/04/19 11:52 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: andymot]
Heinz Offline

Talk Morgan Addict

Registered: 07/09/09
Posts: 3841
Loc: Cologne, Germany
Originally Posted By andymot
Thanks for posting. Seems like a good spare to have in the box - whats the part number/details please? thankyou


+1 Thank you a lot for posting! I never would have thought that this small part could ruin a trip to Italy...

Top
#573459 - 24/04/19 12:41 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: PerryP]
Craig Jezz Offline

Talk Morgan Regular

Registered: 27/03/17
Posts: 947
Loc: Oxon
This same thing happened to my friends 2017. 4/4 anniversary.
_________________________
Craig Jezz

Morgan 4/4 Sports Sand (Williams & Wolf Tuned)

Top
#573462 - 24/04/19 01:29 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: PerryP]
Heinz Offline

Talk Morgan Addict

Registered: 07/09/09
Posts: 3841
Loc: Cologne, Germany
Is this oil pressure sensor only Morgan specific? Did Ford cars have an oil pressure sensor with the same engine? Maybe it's safer to do without the sensor. Was it just an oil pressure switch at Ford Cars that keeps it tight and doesn't need two different threads?
Especially since the display of the oil pressure is hopelessly wrong anyway in my 4/4 I could think about not including this sensor.

Top
#573472 - 24/04/19 02:08 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: PerryP]
sospan Offline
Talk Morgan Sage

Registered: 31/05/10
Posts: 6179
Loc: Llanelli
Sounds like a typical MMC “complication”.
I do wonder at the MMC ability to properly assess the impact of engine changes on ancillary systems.
Is it a case of bung the new engine in and see what happens ?
Morgan owners do seem to be the extended development team too.
Surely a properly designed connection would be straight forward to include in the initial trial fit development stage?
banghead
Quality should be built in from the design stage.
_________________________
Red Plus8

Top
#573513 - 24/04/19 04:43 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: PerryP]
howard Offline
Part of the Furniture

Registered: 01/01/09
Posts: 4303
There was an intriguing comment about the plus 6 that implied for the first time that MMC were using wholy metric nuts and bolts etc. Ties in with this issue. Reminds me of the problems I had at work when new machinery arrived, was of course all metric but within a year the older fitters had managed to change many of the fasterenrs to Whitworth. They found it easier to handle.

I'm willing to bet that an old traditional outfit like MMC has the same issue with their engineers.

Top
#576304 - 12/05/19 08:18 PM Re: PSA - 1.6 Sigma - copper adapter is a weak link [Re: PerryP]
Craig Jezz Offline

Talk Morgan Regular

Registered: 27/03/17
Posts: 947
Loc: Oxon
Is this the copper adaptor (weak link) that can leak on the 4/4 Sigma ?



_________________________
Craig Jezz

Morgan 4/4 Sports Sand (Williams & Wolf Tuned)

Top
Page 1 of 2 1 2 >

Moderator:  Aeroman, Boshly, Simon