Click here to return to the home page.
Morgan Aero 8
Who's Online Now
0 registered members (), 114 guests, and 17 spiders.
Key: Admin, Global Mod, Mod
Top Posters(30 Days)
John V6 430
+8Rich 412
TBM 238
Heinz 189
Newest Topics
Cummings & Goings ;-)
by +8Rich. 03/06/20 08:20 PM
Novochock on TV
by Peter J. 03/06/20 05:43 PM
Happy Birthday
by CooperMan. 03/06/20 02:06 PM
Speedo issue...help!
by Perry. 03/06/20 12:57 PM
One for Rally & BMC fans
by CooperMan. 03/06/20 12:53 PM
Good News
by lowebird. 03/06/20 10:49 AM
Inherent danger with Three Wheelers
by TBM. 03/06/20 10:04 AM
Latest Photos
sump/crossmember guard
The great escape
Sidescreen Mounting in Storage
Are There Any Keen Car Badge Collectors out there
Snow banks of Norway
Newest Members
jaktomaten, Bewifourfour, Sam8888, Brilliant Green, ninrum
6938 Registered Users
Forum Statistics
Forums34
Topics38,410
Posts629,475
Members6,938
Most Online1,033
Dec 28th, 2019
Today's Birthdays
No Birthdays
Previous Thread
Next Thread
Print Thread
S1 Digital mileometer - help please #600560
23/10/19 10:16 AM
23/10/19 10:16 AM
Joined: Aug 2012
Posts: 62
G
gmcn Offline OP
Just Getting Started
gmcn  Offline OP
Just Getting Started
G

Joined: Aug 2012
Posts: 62
Any suggestions please.
The digital display on my mileometer has failed. The speedometer works fine as do all the other instruments but the digital mileage display has gone blank, the display is still illuminated just no numbers. Has anyone any experience of rectifying this problem? Car is a 2002 S1.
Many thanks
Graham

Re: S1 Digital mileometer - help please [Re: gmcn] #600561
23/10/19 10:30 AM
23/10/19 10:30 AM
Joined: Jun 2008
Posts: 1,584
County Down
lightsphere Offline
Talk Morgan Enthusiast
lightsphere  Offline
Talk Morgan Enthusiast

Joined: Jun 2008
Posts: 1,584
County Down
Graham,
This happened to me on quite a few occasions. It seemed to be related to battery problems. I had bought 5 new batteries over a 6 year period, despite CTEC chargers, issolating the battery and praying, those Odyssey batteries let me down annually. A symptom of the battery failure in my case was the fading of mileometer then disappearing. Needles to say all this was accompanied by the starter clicking problem.
There have been others who have reported this on the S1 in the past, not sure how they have solved it.
Hope this helps.

Re: S1 Digital mileometer - help please [Re: gmcn] #600565
23/10/19 11:39 AM
23/10/19 11:39 AM
Joined: Aug 2012
Posts: 62
G
gmcn Offline OP
Just Getting Started
gmcn  Offline OP
Just Getting Started
G

Joined: Aug 2012
Posts: 62
Lightsphere,
Thanks for the quick response, I was having battery / clicking problems, so had a new Odyssey battery fitted and it was driving the car home when I noticed the intermittent display which now seems permanent. Did you manage to recover your display?
Thanks
Graham

Re: S1 Digital mileometer - help please [Re: gmcn] #600620
23/10/19 03:25 PM
23/10/19 03:25 PM
Joined: Mar 2009
Posts: 7,125
Hampshire
Alistair Offline
Smile, it confuses them
Alistair  Offline
Smile, it confuses them
Talk Morgan Guru

Joined: Mar 2009
Posts: 7,125
Hampshire
Yes the S2 is similar.

Low battery voltage and perhaps also damp storage or poor grounding (indicated by the starter issue as well) is a common issue.


Just time to burn a little more petrol before dinner.
Re: S1 Digital mileometer - help please [Re: Alistair] #600637
23/10/19 04:47 PM
23/10/19 04:47 PM
Joined: Aug 2012
Posts: 62
G
gmcn Offline OP
Just Getting Started
gmcn  Offline OP
Just Getting Started
G

Joined: Aug 2012
Posts: 62
Alistair,
Thanks for the reply. Indeed James at Techniques has now said the miloemeter failure is a common problem usually caused by damp. He is going to try a quick fix with a hairdryer. If that fails then it will go off to a specialist instrument shop. The good news is that is it sounds like a sortable problem. Not sure what I would do without this forum and Simon at SIFAB and James at Techniques.
Thanks
Graham

Re: S1 Digital mileometer - help please [Re: gmcn] #600660
23/10/19 06:53 PM
23/10/19 06:53 PM
Joined: May 2016
Posts: 81
South Yorkshire
G
Garethseries1 Offline
Just Getting Started
Garethseries1  Offline
Just Getting Started
G

Joined: May 2016
Posts: 81
South Yorkshire
I have the same problem with my S1 from time to time if I don't use the car for a few weeks but the display comes back after around 20 minutes of driving. I keep the car on a trickle charger so my guess is damp ?

Re: S1 Digital mileometer - help please [Re: gmcn] #601685
30/10/19 06:01 PM
30/10/19 06:01 PM
Joined: Sep 2010
Posts: 1,760
Wales
T
Taffmog Offline
Talk Morgan Enthusiast
Taffmog  Offline
Talk Morgan Enthusiast
T

Joined: Sep 2010
Posts: 1,760
Wales
I have the same problem, I’m sure it’s damp air, driving the car for a few miles with sidelights and heater on and everything returns to normal. The hair dryer sounds a good idea🤔


1969 4/4
1995 plus 8
2002 Aero S1
2013 M3W
2014 Plus 8
Re: S1 Digital mileometer - help please [Re: gmcn] #601690
30/10/19 06:23 PM
30/10/19 06:23 PM
Joined: Aug 2012
Posts: 62
G
gmcn Offline OP
Just Getting Started
gmcn  Offline OP
Just Getting Started
G

Joined: Aug 2012
Posts: 62
Thanks for all the replies. Hair dryer has done the trick.
Graham

Re: S1 Digital mileometer - help please [Re: gmcn] #603316
12/11/19 06:48 PM
12/11/19 06:48 PM
Joined: Jul 2016
Posts: 248
N.Ireland
A
AeroIan Offline
L - Learner Plates On
AeroIan  Offline
L - Learner Plates On
A

Joined: Jul 2016
Posts: 248
N.Ireland
Yep - me too ... thanks for the hairdryer tip


Aero-Ian

Aero 8 Series 1
1980 Porsche 911SC
2003 Defender 90
BMW 330d M Touring

Moderated by  Aeroman, Simon 

Powered by UBB.threads™ PHP Forum Software 7.7.1