Click here to return to the home page.
Morgan Aero 8
Who's Online Now
3 registered members (mph, Alistair, waikiore), 158 guests, and 51 spiders.
Key: Admin, Global Mod, Mod
Top Posters(30 Days)
John V6 444
+8Rich 411
Hawki 180
TBM 160
Newest Topics
Charles @ Britishvolt
by Alistair. 10/07/20 09:40 PM
Hi from Hereford
by Tally Ho. 10/07/20 04:33 PM
Another Oxfordshire newbie
by Aeromax76. 10/07/20 03:58 PM
Electric digger
by TimG. 10/07/20 08:08 AM
Forever Cars -Tiking
by TimG. 10/07/20 08:00 AM
Sweet Painted Lady
by +8Rich. 09/07/20 09:15 PM
door handle cylinder barrels
by BigLes. 09/07/20 07:19 PM
Latest Photos
Another Great Escape. Caister Motor Museum
RUY255 on Autosport Cover
why we love living in the mountains
Our 2020 Morgan Plus 4   110 Anniversary Model
My new Plus Four
Newest Members
Saxonian, GlenB 4475, Simon m wright, dominicalbarn, Sib8292
7053 Registered Users
Forum Statistics
Forums34
Topics38,751
Posts637,090
Members7,053
Most Online1,033
Dec 28th, 2019
Today's Birthdays
Stevey B, Sukram, waikiore
Previous Thread
Next Thread
Print Thread
Page 2 of 2 1 2
Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #636881
11/05/20 10:58 PM
11/05/20 10:58 PM
Joined: Jul 2016
Posts: 125
Essex/Herts border
Volvos60s60 Offline OP
L - Learner Plates On
Volvos60s60  Offline OP
L - Learner Plates On

Joined: Jul 2016
Posts: 125
Essex/Herts border
Hi Gents

So I checked the fuses and all look OK.

With the heater fan speed on max, heater temp set to min, and air con selected, the radiator fans are still not moving at all.

So, I guess I can't even take the car to a specialist as it may well overheat and I would not even know it until damage may have been done.

Maybe I'll just have to take off the wing and replace the temp sensor in the bottom hose, but if that does not work, I'll be pretty much out of ideas. Perhaps also see if I can spot an engine block gauge sensor as well to replace

Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #636884
11/05/20 11:48 PM
11/05/20 11:48 PM
Joined: Feb 2010
Posts: 842
SimonH Offline
Talk Morgan Regular
SimonH  Offline
Talk Morgan Regular

Joined: Feb 2010
Posts: 842
It's not a temperature sensor in the bottom hose
Its the connector for the electronic thermostat for the engine

It's nothing to do with fan control

Simon@Sifab.co.uk
Sifabtemporary@gmail.com


Simon @ Sifab.co.uk

Sifabtemporary@gmail.com
Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #637288
13/05/20 07:19 PM
13/05/20 07:19 PM
Joined: Dec 2013
Posts: 37
A
Aero250 Offline
Just Getting Started
Aero250  Offline
Just Getting Started
A

Joined: Dec 2013
Posts: 37
If you have an OBD code reader you can often get the engine engine temp readings through that and will give confidence the temp sensor is working . It may help you get it to the garage. Note the fans actually come in at a high temp. I think 108c but please confirm with a responsible adult. The fans not coming in with the air con could be low gas or a faulty pressure sensor on the air con side. Let us know how you get on.

Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #637642
15/05/20 10:23 AM
15/05/20 10:23 AM
Joined: Jul 2016
Posts: 125
Essex/Herts border
Volvos60s60 Offline OP
L - Learner Plates On
Volvos60s60  Offline OP
L - Learner Plates On

Joined: Jul 2016
Posts: 125
Essex/Herts border
Hi Simon/Aero250

I have now found a diagram with the location of the the engine thermostat, & looks to be an easy enough job

With respect to the OBD reader, good call. I have one so I'll see if I can get a temp readout which will enable me to see running temp & allow it to run up. Can anyone support the approx 108 deg C cut in temp as Aero250 suggests?

Thanks for all help so far, including Alastair

Ian

Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #637661
15/05/20 11:33 AM
15/05/20 11:33 AM
Joined: Mar 2009
Posts: 7,245
Hampshire
Alistair Online happy
Smile, it confuses them
Alistair  Online Happy
Smile, it confuses them
Talk Morgan Guru

Joined: Mar 2009
Posts: 7,245
Hampshire
It varies on the two I have.

The S2 has a slightly later derivative of your engine and tends to kick in just over 100 - say 103. When driving in open air it stays off and sits around the 90-95 temp.
The Coupe has the bigger 4.8 and runs higher with about 100-102 in normal driving and the fans seem to come in slightly higher as well.

Having the ODB is very helpful on the Aero as you do get a number of things that can cause the engine light to kick in. If you don't get the engine up to temp 2 or 3 times running you can get the engine light on which can be cleared with a good warm run, then off, then another good warm run.


Last edited by Alistair; 15/05/20 11:34 AM.

Just time to burn a little more petrol before dinner.
Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #639748
23/05/20 06:05 PM
23/05/20 06:05 PM
Joined: Jul 2016
Posts: 125
Essex/Herts border
Volvos60s60 Offline OP
L - Learner Plates On
Volvos60s60  Offline OP
L - Learner Plates On

Joined: Jul 2016
Posts: 125
Essex/Herts border
Hi All

I thought I'd update all of you who were kind enough to respond, & also those who might have been interested watchers.

The generic OBD would read out engine revs, mass air flow etc, but not coolant temperature. So having bought an infrared temperature readout gun, and pointed it at the radiator top hose, I was able to run the car up to temperature with some confidence & see one of the twin fans come on which is a relief & it kept the water temperature around 104 deg C (the IR thermometer device has a 2% tolerance). The other fan would not cut in but I am wondering if that is called into service in hot weather countries.

And therefore I feel my problem is either a faulty gauge, wiring or sensor. Easiest to try first is a replacement bottom hose sensor. Would anyone know the (presumably) BMW part number for this

Thanks

Ian

Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #639752
23/05/20 06:13 PM
23/05/20 06:13 PM
Joined: Feb 2010
Posts: 842
SimonH Offline
Talk Morgan Regular
SimonH  Offline
Talk Morgan Regular

Joined: Feb 2010
Posts: 842
The sensor is not in the bottom hose... banghead

That’s the connector for the electronic thermostat...


Simon @ Sifab.co.uk

Sifabtemporary@gmail.com
Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #639762
23/05/20 06:41 PM
23/05/20 06:41 PM
Joined: Jul 2016
Posts: 125
Essex/Herts border
Volvos60s60 Offline OP
L - Learner Plates On
Volvos60s60  Offline OP
L - Learner Plates On

Joined: Jul 2016
Posts: 125
Essex/Herts border
Hi Simon

Thanks - Message received loud & clear :-)

So the only other temp sensor I can see is at the front of the engine above the drive belt and pulleys but I am not sure this is the right one.

You had previously said that the gauge sensor was discreet at the back of the driver's site cylinder head - I can't see it & even if I could it is likely to be a so & so to get at

Ian

Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #639802
23/05/20 09:42 PM
23/05/20 09:42 PM
Joined: Dec 2013
Posts: 37
A
Aero250 Offline
Just Getting Started
Aero250  Offline
Just Getting Started
A

Joined: Dec 2013
Posts: 37
I think that is the only coolant sensor. If you google e38 and e39 BMW’s with the m62 engine you get some useful info. I still think you may be seeing air con issues.

Re: Aero S1 temperature gauge/sensor fault [Re: Volvos60s60] #641222
30/05/20 02:18 PM
30/05/20 02:18 PM
Joined: Jul 2016
Posts: 125
Essex/Herts border
Volvos60s60 Offline OP
L - Learner Plates On
Volvos60s60  Offline OP
L - Learner Plates On

Joined: Jul 2016
Posts: 125
Essex/Herts border
Hi All

Thanks for all your help, also special mention to Simon who had to persevere in getting the message through to me about it not being the bottom hose sensor!

I have replaced the temp sensor at the front of the block, and the gauge now works although somewhat erratically fluctuating rapidly in the lower ranges of the dial, peculiarly only giving a settled reading on a trailing throttle.I can however live with that until it next goes in for a service

Again, many thanks for all of your valued assistance

Ian

Last edited by Volvos60s60; 30/05/20 06:38 PM.
Page 2 of 2 1 2

Moderated by  Aeroman, Simon 

Powered by UBB.threads™ PHP Forum Software 7.7.1