Click here to return to the home page.
Image of a road.
Who's Online Now
11 registered members (jrt, The Austrian, Black Adder, HeadlessBlue, Robbie, Image, LightSpeed, John07, Rog G, JMcL, IcePack), 164 guests, and 16 spiders.
Key: Admin, Global Mod, Mod
Top Posters(30 Days)
John V6 310
+8Rich 284
Peter J 174
Newest Topics
Maintenance Day
by Saxonian. 21/04/21 08:27 AM
How many Morgan 3 Wheelers left to be made?
by Red3W. 21/04/21 07:23 AM
maybe the era hasnt ended.
by howard. 21/04/21 06:58 AM
Brake pads Roadster 3,7
by Mats. 21/04/21 06:51 AM
Headlight bezel
by Tim Caddey. 20/04/21 10:19 PM
Bonnet hinge 97 +8
by Fus969. 20/04/21 06:06 PM
Advice re hardtop front mountings, please
by vbalddave. 20/04/21 09:36 AM
Latest Photos
Lap of the Cairngorms
2017 Sport Blue M3W
Front spoiler
My M3W
Spring has sprung at Hintlesham...
Newest Members
tony1966, Grahameeyore, Animal, prf, Morgs52
7485 Registered Users
Forum Statistics
Forums34
Topics41,048
Posts686,997
Members7,485
Most Online1,033
Dec 28th, 2019
Today's Birthdays
Kurt
Previous Thread
Next Thread
Print Thread
Page 3 of 3 1 2 3
Re: NOT fail on emissions [Re: Grumpy2] #667598
17/10/20 04:07 PM
17/10/20 04:07 PM
Joined: Sep 2016
Posts: 694
Chester, UK
Grumpy2 Offline OP
Talk Morgan Regular
Grumpy2  Offline OP
Talk Morgan Regular

Joined: Sep 2016
Posts: 694
Chester, UK
Ran the obd scanner today, no fault codes and this..

[Linked Image]

[Linked Image]

Engine idling in the garage and up to temp - fan kicking in.

Thoughts?


94 plus 8 in Westminster Green - I think!
Re: NOT fail on emissions [Re: Grumpy2] #667779
18/10/20 10:11 PM
18/10/20 10:11 PM
Joined: Oct 2007
Posts: 243
Sandhurst, Berks
T
teknome Offline
L - Learner Plates On
teknome  Offline
L - Learner Plates On
T

Joined: Oct 2007
Posts: 243
Sandhurst, Berks
I will check readings my Plus 8 in the next few days.

According to the MOT emissions report there was a pass of CO at idle, the failure with CO was at fast idle, did you have a snapshot of a fast idle

R2967 is the standard tune (PROM)

One item that came up some years ago was an issue if the Mass Flowmeter body was not electrically isolated, maybe a heater hose or a grounded item touching it, haven't experienced the problem myself

Checking the tests on my Plus 8 in the last two years it tends to scrape through CO on idle, but sails through on fast idle


---------------------------
Mike Smith


1995 +8
2007 +4
Re: NOT fail on emissions [Re: Grumpy2] #667918
19/10/20 05:03 PM
19/10/20 05:03 PM
Joined: Oct 2007
Posts: 243
Sandhurst, Berks
T
teknome Offline
L - Learner Plates On
teknome  Offline
L - Learner Plates On
T

Joined: Oct 2007
Posts: 243
Sandhurst, Berks

Rovergauge screens from my +8 as follows, the fuel map is very slightly different to standard

first is fast idle at a bit over 3,000 rpm

second is idle at 750

Main difference is that the MAF reading goes up from 3% to 11%, throttle from 6% to 20%, injector duty from 3% to 13% between idle and fast idle

One other check, are you getting any non-metered air entering via a split in the hose from MAF to plenum


[Linked Image]

[Linked Image]


---------------------------
Mike Smith


1995 +8
2007 +4
Re: NOT fail on emissions [Re: Grumpy2] #667925
19/10/20 05:49 PM
19/10/20 05:49 PM
Joined: Sep 2016
Posts: 694
Chester, UK
Grumpy2 Offline OP
Talk Morgan Regular
Grumpy2  Offline OP
Talk Morgan Regular

Joined: Sep 2016
Posts: 694
Chester, UK
Teknome, thanks again for your posts.

Happy to report that we managed to scrape though the emissions today. Replaced the MAF with the cheap Chinese jobby and although it runs less smoothly it did scrape though. Old MAF will be put back on the car!

Yours also runs a bit warmer than mine - I have a sifab aluminium radiator fitted

I’m going to go though all the pipes etc over the coming lock down. Might have a look at the idle valve too.

Thanks all

Gary


94 plus 8 in Westminster Green - I think!
Re: NOT fail on emissions [Re: Grumpy2] #667930
19/10/20 06:03 PM
19/10/20 06:03 PM
Joined: Oct 2007
Posts: 243
Sandhurst, Berks
T
teknome Offline
L - Learner Plates On
teknome  Offline
L - Learner Plates On
T

Joined: Oct 2007
Posts: 243
Sandhurst, Berks
That is good news. I do have a Mulfab radiator, normally run at 80 on the open road, fan keeps it around 90 when stationary. I am temperature gauge watching at the moment as I have just replaced the distributor and don't know if the advance curves are correct, in the process of creating a test fixture as I don't have the money, or a fork lift, to get a SUN distributor tester.


---------------------------
Mike Smith


1995 +8
2007 +4
Re: NOT fail on emissions [Re: teknome] #667938
19/10/20 06:24 PM
19/10/20 06:24 PM
Joined: Dec 2017
Posts: 1,114
Evergreen, Colorado, USA
britmog Offline
Has a lot to Say!
britmog  Offline
Has a lot to Say!

Joined: Dec 2017
Posts: 1,114
Evergreen, Colorado, USA
Originally Posted by teknome
I will check readings my Plus 8 in the next few days.

According to the MOT emissions report there was a pass of CO at idle, the failure with CO was at fast idle, did you have a snapshot of a fast idle

R2967 is the standard tune (PROM)

One item that came up some years ago was an issue if the Mass Flowmeter body was not electrically isolated, maybe a heater hose or a grounded item touching it, haven't experienced the problem myself

Checking the tests on my Plus 8 in the last two years it tends to scrape through CO on idle, but sails through on fast idle


Years ago I had a hesitant running issue with the +8 on checking the airflow meter I found that it was not electrically isolated and the heater hose was causing a grounding resulting in faulty readings. Wrapped the hoses checked the meter for grounding all clear and never had the hesitating again.


Bruce
1964 4/4 Series V Comp (Megan)
1994 +8 (Maurice)
2013 M3W (Olga)
Re: NOT fail on emissions [Re: Grumpy2] #668430
22/10/20 04:49 PM
22/10/20 04:49 PM
Joined: Mar 2011
Posts: 504
Cambridge UK
S
Stephen888 Offline
Talk Morgan Regular
Stephen888  Offline
Talk Morgan Regular
S

Joined: Mar 2011
Posts: 504
Cambridge UK
So pleased mine was 40 years old back in March. So no MOT needed


1980 +8 Blue
----------------
Stephen
Re: NOT fail on emissions [Re: Grumpy2] #668512
23/10/20 07:48 AM
23/10/20 07:48 AM
Joined: Sep 2016
Posts: 694
Chester, UK
Grumpy2 Offline OP
Talk Morgan Regular
Grumpy2  Offline OP
Talk Morgan Regular

Joined: Sep 2016
Posts: 694
Chester, UK
Sorry forgot to reply, there’s no electrical connection between the MAF and the chassis

It got through with a. Combination of the cheap Chinese MAF, cleaning the idle stepper motor and some tweeks but drove awfully. I replaced the MAF with the original one and it drives much better.

Couldn’t resist opening the MAF electronics and having a look at the screw pot. Very interesting. It’s a multi turn pot, six turns takes it from 0 to 100 ohms (checked on the Chinese one) and it would continue Turing if tempted

After lockdown I’m going to take it back to my tester chap and tell him to try multiple turn on the original MAF screw to see if he can get the emissions low enough yet still drivable. Oh and I’ll fit a new stepper motor, plugs and leads too as I’ve nothing better to do but decorate the house for two weeks now!


94 plus 8 in Westminster Green - I think!
Page 3 of 3 1 2 3

Moderated by  TalkMorgan 

Powered by UBB.threads™ PHP Forum Software 7.7.1