Click here to return to the home page.
Image of a road.
Who's Online Now
24 registered members (RichardV6, ewn, 1340fxd, Ollie, bilibib, Ross, RJW, Steve +8, Image, StevieMac, nippymog, The Austrian, MiltonMan, ERaphael, Farmer Giles, peterd, John V6, teifistar, teknome, M3W55, V8Dave, Brian G, Craig Jezz, MikeFromPembroke), 224 guests, and 17 spiders.
Key: Admin, Global Mod, Mod
Top Posters(30 Days)
John V6 299
+8Rich 288
Peter J 178
Newest Topics
1990 Plus 4 Rover M16
by Ross. 18/04/21 09:05 PM
Slow idle issue - 2010 Roadster
by ChrisP. 18/04/21 07:26 PM
My P/101 has officially landed!
by Andrew J.. 18/04/21 03:27 PM
4/4 Sold
by Spanner Juggler. 18/04/21 02:49 PM
Spotted today JNO 482Y
by John V6. 18/04/21 12:17 PM
Scrap a ship in Scotland
by ewn. 17/04/21 07:23 PM
John Dawes
by Scrambledsignals. 17/04/21 06:42 PM
Latest Photos
Lap of the Cairngorms
2017 Sport Blue M3W
Front spoiler
My M3W
Spring has sprung at Hintlesham...
Newest Members
JFPlus4, Garry4, Steven Cheong, Ben25855, Scott G
7473 Registered Users
Forum Statistics
Forums34
Topics41,024
Posts686,569
Members7,473
Most Online1,033
Dec 28th, 2019
Today's Birthdays
Marchogion, markmuk, PhD007
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
Car still running after turning off ignition #691881
05/03/21 12:09 PM
05/03/21 12:09 PM
Joined: Jan 2021
Posts: 10
Dorset
B
bear65 Offline OP
New to Talk Morgan
bear65  Offline OP
New to Talk Morgan
B

Joined: Jan 2021
Posts: 10
Dorset
Hi Everyone, anyone :-)

I have a m3w and everything has been fine.

Today however, this happened:

Turned Key off & on again three times ( as usual ) started car, all good.

Got to the ferry near where I live, tried to switch the ignition off, car carried on running.

Stalled the car to stop the engine, car started fine, off I go.


Same thing happened when I got to work. Started car using Starter Button and Hazard lights came on so I thought I'd drive straight home as the engine was all good, no overheating etc.

Hazard lights e tried turning on the ignition to hear / engage the fuel pump noise, but nothing but Hazard lights coming on.

Now I don't hear the fuel pump noise when turning on the ignition for ' pre start routine " - Any advice gaudy appreciated.


Last edited by bear65; 05/03/21 02:01 PM.

2016 M3W
1937 AJS 26s combination
1928 Rudge Special
Re: Car still running after turning off ignition [Re: bear65] #691888
05/03/21 12:48 PM
05/03/21 12:48 PM
Joined: Jul 2018
Posts: 709
M3W55 Online content
Talk Morgan Regular
M3W55  Online Content
Talk Morgan Regular

Joined: Jul 2018
Posts: 709
Craig

I would suggest that you re-post this in the M3W forum as the Three Wheeler experts may not spot it here.

Re: Car still running after turning off ignition [Re: bear65] #691890
05/03/21 12:59 PM
05/03/21 12:59 PM
Joined: Dec 2008
Posts: 19,315
South Yorkshire
DaveW Online content
Roadster Guru
DaveW  Online Content
Roadster Guru
Member of the Inner Circle

Joined: Dec 2008
Posts: 19,315
South Yorkshire
This sounds like a sticking ignition relay????


DaveW
2005 Corsa Red Roadster S1
2016 Saffron Yellow (Narrow) AR Plus 4
Re: Car still running after turning off ignition [Re: bear65] #691898
05/03/21 01:39 PM
05/03/21 01:39 PM
Joined: May 2011
Posts: 1,329
Near Windsor Berkshire
R
Rog G Offline
Has a lot to Say!
Rog G  Offline
Has a lot to Say!
R

Joined: May 2011
Posts: 1,329
Near Windsor Berkshire
It is likely to be the indicator module, a lot of feeds seem to go through this, check out this thread page 2 onwards

http://www.talkmorgan.com/ubbthreads.php/topics/517471/re-near-side-indicator-issue#Post517471

Excerpt below

"I had a problem with the full beam which could not be switched on. The dealer thought it was a wiring problem but could not find the fault. They tried a new indicator assembly but the fault was still there

On my way to the MTWC opening run the hazard warning lights came on, all the lights on the dashbord lit up and when I tried to switch off the engine it kept running with the key out of the ignition!

The M3W was driven to the hotel where the only way to stop the engine was to stall it and after that it would not start

Skullmog spent over 2 hours on the Saturday evening trying to find the problem and after ruling out fuses, relays, immobiliser and ECU he thought it was the cambus. Thanks again Kevin for your help

The vehicle was trailered back to the dealer and 4.5 weeks later was fixed, the problem being the indicator module unit. On the invoice it was shown as M3W TURN SIGNAL HEADLAMP MODULE and was £39.89 plus VAT

The old part was given to Skullmog for him to look at

At the time we, the MTWC, did not know of anyone else having a problem with this unit"

There have been a number of other instance since.

Last edited by Rog G; 05/03/21 01:40 PM.

2013 M3W
1971 4/4 2 Seater
1934 Sports
Re: Car still running after turning off ignition [Re: bear65] #691901
05/03/21 01:46 PM
05/03/21 01:46 PM
Joined: Jul 2013
Posts: 3,171
West Sussex, UK
Chris99 Offline
Talk Morgan Addict
Chris99  Offline
Talk Morgan Addict

Joined: Jul 2013
Posts: 3,171
West Sussex, UK
+1 - Rog types quicker than I do.................


Red Leader drive
Re: Car still running after turning off ignition [Re: M3W55] #691907
05/03/21 02:24 PM
05/03/21 02:24 PM
Joined: Jan 2021
Posts: 10
Dorset
B
bear65 Offline OP
New to Talk Morgan
bear65  Offline OP
New to Talk Morgan
B

Joined: Jan 2021
Posts: 10
Dorset
Thanks

But been struggling to find out how you actually choose a forum then post


2016 M3W
1937 AJS 26s combination
1928 Rudge Special
Re: Car still running after turning off ignition [Re: Rog G] #691908
05/03/21 02:24 PM
05/03/21 02:24 PM
Joined: Jan 2021
Posts: 10
Dorset
B
bear65 Offline OP
New to Talk Morgan
bear65  Offline OP
New to Talk Morgan
B

Joined: Jan 2021
Posts: 10
Dorset
Massive thanks everyone


2016 M3W
1937 AJS 26s combination
1928 Rudge Special
Re: Car still running after turning off ignition [Re: DaveW] #691909
05/03/21 02:27 PM
05/03/21 02:27 PM
Joined: Jan 2021
Posts: 10
Dorset
B
bear65 Offline OP
New to Talk Morgan
bear65  Offline OP
New to Talk Morgan
B

Joined: Jan 2021
Posts: 10
Dorset
Thanks Dave


2016 M3W
1937 AJS 26s combination
1928 Rudge Special
Re: Car still running after turning off ignition [Re: bear65] #691913
05/03/21 02:45 PM
05/03/21 02:45 PM
Joined: Jul 2018
Posts: 709
M3W55 Online content
Talk Morgan Regular
M3W55  Online Content
Talk Morgan Regular

Joined: Jul 2018
Posts: 709
The indicator module on that vehicle was replaced a year ago after it burnt out.

Re: Car still running after turning off ignition [Re: M3W55] #691918
05/03/21 03:22 PM
05/03/21 03:22 PM
Joined: Dec 2011
Posts: 369
Lincolnshire, the hilly bit!
H
hugo Offline
Learner Plates Off!
hugo  Offline
Learner Plates Off!
H

Joined: Dec 2011
Posts: 369
Lincolnshire, the hilly bit!
+1 Indicator relay, i had exactly the same symptoms on my car.


2012 M3W
1981 Lambretta GP225
1955 James Trials
2015 Scomadi 125
Page 1 of 2 1 2

Moderated by  TalkMorgan 

Powered by UBB.threads™ PHP Forum Software 7.7.1