Click here to return to the home page.
Morgan 3 Wheeler
Who's Online Now
3 registered members (Cuna2016, ChrisConvertible, Edwin), 287 guests, and 18 spiders.
Key: Admin, Global Mod, Mod
Top Posters(30 Days)
+8Rich 304
John V6 206
OZ 4/4 167
CooperMan 162
RichardV6 142
Newest Members
Alford, Mogge77, Kevin McMillen, Corrosion Guy, Supernano
8072 Registered Users
Newest Topics
Sospan a warning
by +8Rich. 14/08/22 05:08 PM
Sprint day at Goodwood 13 august 2022
by Nick55. 14/08/22 04:24 PM
Boxster S Drives
by Peter J. 14/08/22 01:36 PM
Black Trad headlight rim
by John V6. 14/08/22 11:38 AM
Clear side repeaters for trads
by John V6. 14/08/22 08:54 AM
Fuel sending unit screws
by Rattler. 13/08/22 10:58 PM
Latest Photos
4/4 75th Anniversary
Around the Cairngorms
Big Skies
More from Helmingham
Helmingham Hall Car Show 7.8.22
Forum Statistics
Forums34
Topics43,863
Posts738,739
Members8,072
Most Online1,033
Dec 28th, 2019
Today's Birthdays
2to3wheels
Previous Thread
Next Thread
Print Thread
Page 1 of 2 1 2
M3W Help wanted! #743393
31/05/22 11:43 PM
31/05/22 11:43 PM
Joined: Sep 2010
Posts: 2,104
Wales
T
Taffmog Offline OP
Talk Morgan Expert
Taffmog  Offline OP
Talk Morgan Expert
T

Joined: Sep 2010
Posts: 2,104
Wales
Took the mistress out the weekend, 2013, 1700 miles with all upgrades, runs for 1/4 mile then cuts out, no warning, no coughing or spluttering, refuses to start for an hour or so then fires and process repeated 1/4 mile down the road. Turns over ok but refuses to fire. Idling and revving in garage it shows charge at 14.3 volts so I think the rectifier is ok. I don't suspect the fuel pump as cut out is instant, Factory suspect ECU and offered me a replacement to try. I do have a problem in that if I do a test drive and having to tow it home again I can't get it up my sloping drive into the garage 😫. Occasionally there's a smell of petrol when attempting to start ( an hour is a long time at the side of the road!) but plugs were dry and looked good. Last time it ran under load it did sound a bit rough, not exactly a misfire though, idling and revving it garage appears ok. Any thoughts Gents?


1969 4/4
1995 plus 8
2002 Aero S1
2013 M3W
2014 Plus 8
Re: M3W Help wanted! [Re: Taffmog] #743394
01/06/22 01:27 AM
01/06/22 01:27 AM
Joined: Jun 2016
Posts: 416
New Jersey, USA
truckin-on Offline
Learner Plates Off!
truckin-on  Offline
Learner Plates Off!

Joined: Jun 2016
Posts: 416
New Jersey, USA
When it dies, and you go to try to re-start it, do you hear the fuel pump run for a few seconds when you turn the ignition on? I believe it always fires the pump, even if the lines are already pressurized. If you don't hear that - when it doesn't start - it's the pump. Would be my suspicion rather than the ECU.

Re: M3W Help wanted! [Re: truckin-on] #743397
01/06/22 03:18 AM
01/06/22 03:18 AM
Joined: Aug 2011
Posts: 390
Auckland New Zealand
P964 Offline
Learner Plates Off!
P964  Offline
Learner Plates Off!

Joined: Aug 2011
Posts: 390
Auckland New Zealand
Faulty connection of the kill switch? Have been threads on this so suggest a quick search

Re: M3W Help wanted! [Re: Taffmog] #743407
01/06/22 07:18 AM
01/06/22 07:18 AM
Joined: Jul 2013
Posts: 3,346
West Sussex, UK
Chris99 Offline
Talk Morgan Addict
Chris99  Offline
Talk Morgan Addict

Joined: Jul 2013
Posts: 3,346
West Sussex, UK
I'd suspect the fuel pump, particularly if the plugs are dry.

It will cut out suddenly if it loses fuel pressure and can restart after a while so that all fits. Check for 58psi at the Schrader valve near the injectors or, just replace with a Walbro anyway as this is a worthwhile upgrade.

The ECU is far less likely as there have been very few reported failures.


Red Leader drive
Re: M3W Help wanted! [Re: Taffmog] #743442
01/06/22 01:42 PM
01/06/22 01:42 PM
Joined: Feb 2019
Posts: 3,639
Port Orchard, WA.
LightSpeed Offline
Talk Morgan Addict
LightSpeed  Offline
Talk Morgan Addict

Joined: Feb 2019
Posts: 3,639
Port Orchard, WA.
My vote is for the fuel pump. Mine did that sort of activity before it died completely.

Re: M3W Help wanted! [Re: Taffmog] #743463
01/06/22 04:18 PM
01/06/22 04:18 PM
Joined: May 2011
Posts: 1,445
Near Windsor Berkshire
R
Rog G Offline
Has a lot to Say!
Rog G  Offline
Has a lot to Say!
R

Joined: May 2011
Posts: 1,445
Near Windsor Berkshire
Fuel pump. There was a M3W on our Cornish trip in March, the engine just stopped with no prior warning it would turn over with a slight hint that it was trying to fire but wouldn't , we changed the fuel pump at the side of the road and it started straight away. I believe it has done over 1000 miles since without a hint of any other issue.


2021 M3W
2013 M3W - Sold
1971 4/4 2 Seater
1934 Sports
Re: M3W Help wanted! [Re: Taffmog] #743467
01/06/22 04:40 PM
01/06/22 04:40 PM
Joined: Aug 2016
Posts: 155
Worcestershire
J
Jonathan G Offline
L - Learner Plates On
Jonathan G  Offline
L - Learner Plates On
J

Joined: Aug 2016
Posts: 155
Worcestershire
Fuel pump - I had the same problem!


2021 Morgan Plus Four
2012 Morgan Three Wheeler
2020 Land Rover Defender 110
Re: M3W Help wanted! [Re: Taffmog] #743478
01/06/22 06:35 PM
01/06/22 06:35 PM
Joined: Aug 2013
Posts: 1,527
Cheshire, UK
nippymog Offline
Talk Morgan Enthusiast
nippymog  Offline
Talk Morgan Enthusiast

Joined: Aug 2013
Posts: 1,527
Cheshire, UK
Something I have never done, and would only do with extreme caution ...
To prove its a fuel problem , how about taking the plugs out and squirting a small amount of fuel in each cylinder , put the plugs back and try it.
If it fires , it fuel.
Does this sound reasonable? and issues doing this ?

Re: M3W Help wanted! [Re: Taffmog] #743487
01/06/22 08:40 PM
01/06/22 08:40 PM
Joined: Feb 2021
Posts: 107
Central CT/Newport, RI
M
MichaelS Offline
L - Learner Plates On
MichaelS  Offline
L - Learner Plates On
M

Joined: Feb 2021
Posts: 107
Central CT/Newport, RI
Ditto on likely fuel pump. As mentioned, when you turn on the key, if you don't hear the hum, that's it. Beware of false positives. If it does start, let it idle. If the pump is bad, it will die again soon enough. Sometimes it takes a few cycles to die completely. Mine failed at 2500 miles in my '17.


Formerly and Still '06032'
2017 M3W, 2008 Ural Patrol
Other stuff....
Re: M3W Help wanted! [Re: Taffmog] #743496
02/06/22 07:39 AM
02/06/22 07:39 AM
Joined: Jun 2019
Posts: 29
B
Barrythebrave Offline
Just Getting Started
Barrythebrave  Offline
Just Getting Started
B

Joined: Jun 2019
Posts: 29
I had an intermittent issue like this, got myself a Fuel Injection Gauge Pressure Tester Test Kit from Ebay. Took the guess work out of it. Cost was around £25 at the time
Was the fuel pump BTW
Fuel Gauge

Re: M3W Help wanted! [Re: Taffmog] #743499
02/06/22 08:54 AM
02/06/22 08:54 AM
Joined: Mar 2014
Posts: 1,459
Leicestershire, UK
Bunny Offline
Has a lot to Say!
Bunny  Offline
Has a lot to Say!

Joined: Mar 2014
Posts: 1,459
Leicestershire, UK
This link takes you to FUEL PUMP REPLACEMENT GUIDE. It's a straight-forward DIY job but remember that there may be slight differences in the hardware used depending on what MMC had available at the time of manufacture.


Andy
Re: M3W Help wanted! [Re: Taffmog] #746298
28/06/22 09:16 PM
28/06/22 09:16 PM
Joined: Sep 2010
Posts: 2,104
Wales
T
Taffmog Offline OP
Talk Morgan Expert
Taffmog  Offline OP
Talk Morgan Expert
T

Joined: Sep 2010
Posts: 2,104
Wales
Hi guys, thanks for all your input, done nothing as yet other than the purchase of a Walpro pump and also a US Pro fuel pump pressure testing kit off eBay, an absolute bargain at less than £25. The Factory are adamant that it is the Crank position sensor but have none in stock. My idea was to drive the car until it stopped then change the sensor at the side of the road as opposed to having to change the fuel pump. The sensor looks suspiciously like a Harley one, Anyone know? Thanks in advance.......


1969 4/4
1995 plus 8
2002 Aero S1
2013 M3W
2014 Plus 8
Re: M3W Help wanted! [Re: Taffmog] #746311
29/06/22 05:44 AM
29/06/22 05:44 AM
Joined: Sep 2019
Posts: 113
Lot et Garonne, France
S
Stevo666 Offline
L - Learner Plates On
Stevo666  Offline
L - Learner Plates On
S

Joined: Sep 2019
Posts: 113
Lot et Garonne, France
"The sensor looks suspiciously like a Harley one, Anyone know?"

The Harley sensors are shorter so will not fit....its a bespoke S&S part....

If it was a sudden engine cut then I would also agree to faulty crank sensor (which will also give symptoms of a faulty fuel pump) but change the fuel pump regardless as it is worthwhile doing so.

Re: M3W Help wanted! [Re: Stevo666] #746346
29/06/22 02:02 PM
29/06/22 02:02 PM
Joined: Dec 2017
Posts: 1,559
Evergreen, Colorado, USA
britmog Offline
Talk Morgan Enthusiast
britmog  Offline
Talk Morgan Enthusiast

Joined: Dec 2017
Posts: 1,559
Evergreen, Colorado, USA
Originally Posted by Stevo666
If it was a sudden engine cut then I would also agree to faulty crank sensor (which will also give symptoms of a faulty fuel pump) but change the fuel pump regardless as it is worthwhile doing so.


I agree change the fuel pump or you will regret not doing so.


Bruce
1964 4/4 Series V Comp (Megan)
1994 +8 (Maurice)
2013 M3W (Olga)
Re: M3W Help wanted! [Re: Taffmog] #746409
29/06/22 11:35 PM
29/06/22 11:35 PM
Joined: Sep 2010
Posts: 2,104
Wales
T
Taffmog Offline OP
Talk Morgan Expert
Taffmog  Offline OP
Talk Morgan Expert
T

Joined: Sep 2010
Posts: 2,104
Wales
Thanks for that Stevo666


1969 4/4
1995 plus 8
2002 Aero S1
2013 M3W
2014 Plus 8
Re: M3W Help wanted! [Re: Taffmog] #746681
02/07/22 06:32 PM
02/07/22 06:32 PM
Joined: Nov 2017
Posts: 54
M
MOR404 Offline
Just Getting Started
MOR404  Offline
Just Getting Started
M

Joined: Nov 2017
Posts: 54
I had the same problem on and after replacing many parts it turned out to be the Crank Position Sensor. It is a different engine to yours but when I went to the agent of the engine to order the part he asked me for Euros200 but I bought the same part by the same manufacturer for euros40. Very often these sensors are used on different cars so it might be worth checking that. If I am not mistaken I think there is a thread with a list of parts on Talkmorgan where you can find the same replacement part and the car it is used on. I spent a lot of time and money to fix the fault but at least I now know my trike much better. Phase sensor faults could be intermittent and could prove very dangerous on the road

Re: M3W Help wanted! [Re: Taffmog] #746701
02/07/22 10:04 PM
02/07/22 10:04 PM
Joined: May 2019
Posts: 480
Hampshire, UK
I
IMHO Offline
Learner Plates Off!
IMHO  Offline
Learner Plates Off!
I

Joined: May 2019
Posts: 480
Hampshire, UK
Originally Posted by Taffmog
Hi guys, thanks for all your input, done nothing as yet other than the purchase of a Walpro pump and also a US Pro fuel pump pressure testing kit off eBay, an absolute bargain at less than £25. The Factory are adamant that it is the Crank position sensor but have none in stock. My idea was to drive the car until it stopped then change the sensor at the side of the road as opposed to having to change the fuel pump. The sensor looks suspiciously like a Harley one, Anyone know? Thanks in advance.......


I have the same pressure testing kit, mine didn’t come with the right size Schraeder adaptor, did you manage to locate one?


M3W Brooklands (2015)
Moody 41 (2013)
Re: M3W Help wanted! [Re: MOR404] #746753
03/07/22 02:31 PM
03/07/22 02:31 PM
Joined: Jun 2010
Posts: 665
France
Black Adder Offline
Toys for Boys
Black Adder  Offline
Toys for Boys
Talk Morgan Regular

Joined: Jun 2010
Posts: 665
France
Originally Posted by MOR404
I had the same problem on and after replacing many parts it turned out to be the Crank Position Sensor. It is a different engine to yours but when I went to the agent of the engine to order the part he asked me for Euros200 but I bought the same part by the same manufacturer for euros40. Very often these sensors are used on different cars so it might be worth checking that. If I am not mistaken I think there is a thread with a list of parts on Talkmorgan where you can find the same replacement part and the car it is used on. I spent a lot of time and money to fix the fault but at least I now know my trike much better. Phase sensor faults could be intermittent and could prove very dangerous on the road


If anyone has a source or a compatible alternative part for an X-Wedge Crank Position sensor then please let me know, as I have need of one.


Omne trium perfectum
Re: M3W Help wanted! [Re: Black Adder] #746787
04/07/22 05:47 AM
04/07/22 05:47 AM
Joined: Nov 2017
Posts: 54
M
MOR404 Offline
Just Getting Started
MOR404  Offline
Just Getting Started
M

Joined: Nov 2017
Posts: 54
Probably it’s the same one used by Harley Davidson. If you go on eBay I am sure you will find the required part

Re: M3W Help wanted! [Re: MOR404] #746799
04/07/22 10:03 AM
04/07/22 10:03 AM
Joined: Mar 2014
Posts: 1,459
Leicestershire, UK
Bunny Offline
Has a lot to Say!
Bunny  Offline
Has a lot to Say!

Joined: Mar 2014
Posts: 1,459
Leicestershire, UK
Originally Posted by MOR404
Probably it’s the same one used by Harley Davidson. If you go on eBay I am sure you will find the required part
I would love to be proved wrong but I think in this case the CPS is unique to the X-Wedge. The Harley ones unfortunately won't fit because they are around 10mm too short. I'll start a new thread to see if we can track down an alternative.

Last edited by Bunny; 04/07/22 10:06 AM.

Andy
Page 1 of 2 1 2

Moderated by  TalkMorgan 

Powered by UBB.threads™ PHP Forum Software 7.7.1