Talk Morgan

Offside lights gone out

Posted By: Kevcaster

Offside lights gone out - 07/11/19 04:47 PM

I arrived back from a run today to notice that both the offside front lamps had stopped working, wing lamps and headlamps/side lamps. I looked at the fuses but all seems fine, nearside lights are all working - this seems strange, any one out there with ideas on this?
Posted By: MOG 615

Re: Offside lights gone out - 07/11/19 05:23 PM

Have a look at the earth connections for the offside?
Posted By: sospan

Re: Offside lights gone out - 07/11/19 05:40 PM

Also check the condition of the wiring under the wing. It is a tough environment. I replaced the bullet connectors on mine as they were badly corroded and intermittent lighting issues., I had to cut them off as they were solid. Replaced and sealed the new spade ones with shrink tubing.
Posted By: Graham, G4FUJ

Re: Offside lights gone out - 07/11/19 07:34 PM

Proper electrical test of the relevant fuse necessary. Often visual checks are insufficient.
If it has blown you will want to find why - did you have anything plugged into the accessory socket (which may well be on the same fuse)?
Posted By: Richard Wood

Re: Offside lights gone out - 07/11/19 08:32 PM

It's not the fuse if it affects both headlamp and sidelights, but likely a common earth. There is a four way connector behind offside headlamp bowl. The wiring diagram suggests this is in a bag taped to back of bowl. Check the black earth wire integrity here. If ok then check the actual chassis earth by tracing the black wire that runs to 5mm ring connector bolted to chassis/wing.
Posted By: Kevcaster

Re: Offside lights gone out - 07/11/19 09:52 PM

OK much appreciate the information. I will take a look tomorrow morning and see if it might be within my limited capability, otherwise a trip to Bell and Colvill for a warranty fix.
Yesterday I took it to them for a diff leak investigation, on the way the engine warning light came on which they reset. Today it came on again and so I imagine that something is going on in the labyrinth.
As you can probably sense I’m less than a novice at anything to do with cars and especially electrics which of course is a form of magic.
Posted By: The Austrian

Re: Offside lights gone out - 08/11/19 07:00 AM


Check the connections next to the wiper motor.
If connections got loose there some strange effects may be the result.
Posted By: John V6

Re: Offside lights gone out - 08/11/19 02:49 PM

With mine it was the earths.
Posted By: britmog

Re: Offside lights gone out - 08/11/19 03:20 PM

The Golden rule with Morgans regarding electrical issues is first check the Earths. The Prince of Darkness lurks everywhere!!
Posted By: The Austrian

Re: Offside lights gone out - 12/11/19 05:56 AM

Kevin: did you find the bug?
Posted By: Kevcaster

Re: Offside lights gone out - 24/11/19 08:41 PM

Hi Hannes, no I did not find it. The car goes in for electrics, a small coolant leak and the diff leak next week. Hopefully that will sort it out. It turns out that the sidelights only, the reversing lights and the brake lights are all not working, the engine light is still on too. Gremlins and witchcraft at work
Originally Posted by The Austrian
Kevin: did you find the bug?
Posted By: Kevcaster

Re: Offside lights gone out - 05/12/19 08:17 PM


Originally Posted by Graham, G4FUJ
Proper electrical test of the relevant fuse necessary. Often visual checks are insufficient.
If it has blown you will want to find why - did you have anything plugged into the accessory socket (which may well be on the same fuse)?

You were right Graham it turned out to be a fuse
Kevin
Posted By: Kevcaster

Re: Offside lights gone out - 05/12/19 08:33 PM

Originally Posted by Kevcaster
Hi Hannes, no I did not find it. The car goes in for electrics, a small coolant leak and the diff leak next week. Hopefully that will sort it out. It turns out that the sidelights only, the reversing lights and the brake lights are all not working, the engine light is still on too. Gremlins and witchcraft at work
Originally Posted by The Austrian
Kevin: did you find the bug?


Hannes
This has been mostly sorted by the dealer. A faulty fuse was replaced and the lights are back working.
The engine warning light was on as the EGR valve was found to be faulty, this has been replaced and the engine is now much more willing to rev, smoother, pulls better and sounds better. It has also lost the faint tapping sound it had on start up.
The diff cover was replaced and the coolant hoses tightened and therefore both leaks fixed.
In the process of all this the heater fan switch got disconnected somehow and I discovered while checking all the lights that the foglight was not working. I opened it tonight to see if it was just a bulb and found it waterlogged and rusted solid ........ ho hum..... back to the dealer
Kevin
Posted By: Graham, G4FUJ

Re: Offside lights gone out - 07/12/19 09:07 AM

Thanks for the update thumbs
© 2019 Talk Morgan - Morgan Sports Car Discussion Forum, Community and News